LOUNGE all new asksnapzu ideasforsnapzu newtribes interesting pics videos funny technology science technews gaming health history worldnews business web research entertainment food living internet socialmedia mobile space sports photography nature animals movies culture travel television finance music celebrities gadgets environment usa crime politics law money justice psychology security cars wtf art google books lifetips bigbrother women apple kids recipes whoa military privacy education facebook medicine computing wildlife design war drugs middleeast diet toplists economy fail violence humor africa microsoft parenting dogs canada neuroscience architecture religion advertising infographics sex journalism disaster software aviation relationships energy booze life japan ukraine newmovies nsa cannabis name Name of the tribe humanrights nasa cute weather gifs discoveries cops futurism football earth dataviz pets guns entrepreneurship fitness android extremeweather fashion insects india northamerica
parent
  • Schwut
    +1
    @Saltystew -

    That seems really weird. I have a gtx 960 and everything went fine with driver manager.

  • Saltystew
    +1
    @Schwut -

    Well I'm no expert obviously. So it may have just been my fault.

  • Schwut
    +1
    @Saltystew -

    I doubt it's your fault. There isn't much you can mess up with driver manager.

    • Saltystew
      +1
      @Schwut -

      Then I got nothin. Unless there was some update in the package manager that messed it up, because that's all I did after installing the new driver.